Incorrect Information Displayed on TLCF Website

Incident Report for The Luc Cochran Foundation

Resolved

Earlier today, several pages on the TLCF website displayed outdated or incorrect content, including staff names and program information. The issue was related to a caching and publishing conflict following recent updates.

Resolution:
As of 8:21 PM EDT, all affected pages have been refreshed. The website now reflects the most current and accurate information, including a new updated layout and design improvements.

Current Status:
✅ Content fully restored
✨ Visual and structural refresh now live
🔐 No data or functional systems were impacted

We appreciate your patience and understanding as we worked to resolve this issue.
Posted Jun 29, 2025 - 20:22 EDT

Identified

We are aware of an issue affecting content accuracy on several TLCF website pages. This includes incorrect or outdated staff names, program details, and other informational sections.

Current Findings:
• Staff pages may reflect incorrect personnel listings.
• Program descriptions may not align with the most current updates.
• The issue appears to stem from a caching conflict or recent publishing error.

Impact:
This is a display-only issue. All donation systems, appointment bookings, and core services remain fully functional and secure.

Response:
Our IT and Communications teams are actively working to correct and refresh the affected content. A content flush and integrity check are underway.
Posted Jun 29, 2025 - 17:15 EDT
This incident affected: Main Website, Shareholder Site, and Financial News Site.